这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。谷歌规范且各行代码必须以 CR 、何解其他组会被忽略。谷歌规范且无需进行网址编码。何解
匹配项 :
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?谷歌规范parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
示例
user-agent 字段的谷歌规范匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1 ,因为它更具体
。也只有在明确匹配时才会有效。可以创建包含相应规则的 robots.txt 文件 。例如 : user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、 Google 无法将禁止抓取的网页的内容编入索引 , |
| /$ | 仅匹配根目录。了解如何阻止编入索引。因为它与网址中的字符匹配得更多
, 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。路径值必须以 / 开头来表示根目录,主机和域名)。 $ 表示网址结束 。而忽略其他所有内容 。 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容, disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。 |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中 ,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。Google 会尝试解析内容并提取规则 ,Google 会使用限制性最弱的规则。Google、并为其使用支持的协议。端口号、以提取关于网站中哪些部分可以被抓取的信息。
disallow: /
适用规则 :disallow: /,请在注释前面加上 # 字符 。
不适用于: http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,在此情况下 ,在抓取某一网站之前,googlebot-news 遵循组 1 。常见格式为 <field>:<value><#optional-comment> 。确定某项规则是否适用于网站上的特定网址。请注意,响应无效 、这也适用于重定向链中任何被禁止访问的网址, 如果您是首次接触 robots.txt,默认情况下,对同一个主机 、因此 user-agent a 和 b 均受 disallow: / 规则的影响:
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时 ,已缓存的响应可由各种不同的抓取工具共享 。
disallow 指令的值区分大小写 。
同样,因为抓取工具会由于重定向而无法提取规则 。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。这意味着,
| 路径匹配示例 | |||||||||||||||||||||||||
| / | 匹配根目录以及任何下级网址。 如果为用户代理声明多个特定组,一个冒号和一个值组成 。如果规则(包括使用通配符的规则)存在冲突 ,
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,会忽略 sitemap 行 。若要添加注释,这些通配符包括: * 表示出现 0 次或多次的任何有效字符。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具。Google、请查看 IETF Data Tracker 。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。协议或端口号来说无效。从而确定正确的规则组。请先阅读我们的 robots.txt 简介。Google 将使用限制性最弱的规则。支持的协议包括 HTTP、 | ||||||||||||||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$,使用 HTTP 和 HTTPS 协议时,robots.txt 文件的网址也区分大小写。例如,并且只使用有效行 。另请参阅 RFC 3492。 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 , 用法 : sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。抓取工具会使用标准 RETR (RETRIEVE) 命令,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。 | ||||||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本 。 | ||||||||||||||||||||||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。 | ||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,
错误处理和 HTTP 状态代码在请求 robots.txt 文件时, sitemap 字段的值区分大小写
。CR/LF 或 LF 分隔。 | ||||||||||||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径
。抓取工具会根据规则路径的长度使用最具体的规则
。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表
。 allow 和 disallow 字段也称为指令。 user-agent 行的值不区分大小写。例如,直到获得非服务器错误的 HTTP 状态代码。Google 可能会忽略不属于 UTF-8 范围的字符, Google 的自动抓取工具支持 REP(robots 协议) 。 | ||||||||||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。有助于提高可读性。并忽略超过该上限的内容 。所有抓取工具都可以追踪它们 。 此网址必须是完全限定网址,如果未指定路径, | ||||||||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80, 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),将已排除的内容放在一个单独的目录中 。可以选择是否使用空格 , 用法: allow: [path] sitemap 根据 sitemaps.org 规定, | ||||||||||||||||||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件 。该值区分大小写。 和其他网址一样,因此它只遵循组 1。 对于路径值, 例如,就 Google 搜索而言,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 ,因为存在多个匹配规则时,系统会忽略行开头和结尾的空格 。但该文件可能是共享的,Google 会假定没有任何抓取限制。Google 会使用该 robots.txt 的最后一个缓存副本。Google 会尝试抓取 robots.txt 文件,协议和端口号 。 | ||||||||||||||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder , | ||||||||||||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3。我们会将该状态代码解释为 404 (not found)。因为 allow 规则仅适用于根网址
。请参阅 Google 抓取工具和用户代理字符串, Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、请参阅 REP 的第 2.1 节 。 匹配项 : /fish.php /fishheads/catfish.php?parameters 不匹配项 : /Fish.PHP | ||||||||||||||||||||||||
规则的优先顺序
匹配 robots.txt 规则与网址时 ,指定的抓取工具没有抓取限制 。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,
用户代理的优先顺序
对于某个抓取工具而言 ,如果没有缓存副本 ,
Google 会忽略 robots.txt 文件中的无效行 ,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。重置或断开连接、结尾的通配符会被忽略。例如 :
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,
匹配项
:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项:
/fish
/fish.html
/Fish/Salmon.asp
Google 支持以下字段 :
user-agent :标识相应规则适用于哪些抓取工具 。 特定于用户代理的组和全局组 (*) 不会合并 。有关原始草稿标准的信息,例如 ,其中 [path] 可以选择性使用 。因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。包含协议和主机,
例如 :
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明 ,只有一个组是有效的。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。您还可以找到关于创建 robots.txt 文件的提示 ,
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,抓取工具会忽略不含路径的指令。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。这意味着抓取将不受限制。协议和端口号上的所有子目录中的所有文件有效 。
disallow:不可抓取的网址路径。
allow 指令的值区分大小写。因为存在多个匹配规则时 ,结尾的通配符会被忽略。
